diff mbox series

[bug#64209,v4,06/11] gnu: Add ocamlc-loc.

Message ID 871a1970083eac598f41207500622ae90f93d103.1711236338.git.benjamin@uvy.fr
State New
Headers show
Series Update with rebase on master | expand

Commit Message

Benjamin March 23, 2024, 11:35 p.m. UTC
* gnu/packages/ocaml.scm (ocamlc-loc): New variable.

Change-Id: I0bcc2666d8030f067b964647400ff31e9302d1c7
---
 gnu/packages/ocaml.scm | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 8def4c18aa..08d4cea003 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8799,6 +8799,22 @@  (define-public dune-rpc
     (synopsis "Communicate with ocaml dune using rpc")
     (description "Library to connect and control a running dune instance.")))
 
+(define-public ocamlc-loc
+  (package
+    (inherit dune-ordering)
+    (name "ocamlc-loc")
+    (build-system dune-build-system)
+    (arguments
+     '(#:package "ocamlc-loc"
+       ;; Tests have a cyclic dependency on stdune
+       #:tests? #f))
+    (propagated-inputs (list dune-dyn ocaml-odoc))
+    (synopsis "Parse ocaml compiler output into structured form")
+    (description
+     "This library parses ocaml complier output and returns it as ocaml values.
+This library offers no backwards compatibility guarantees.")))
+
+
 (define-public ocaml-either
   (package
     (name "ocaml-either")