diff mbox series

[bug#64209,v4,02/11] gnu: Add ocaml-ppx-yojson-conv-lib.

Message ID bcecbb53bb36ea8697434ee2531e413020222933.1711236338.git.benjamin@uvy.fr
State New
Headers show
Series Update with rebase on master | expand

Commit Message

Benjamin March 23, 2024, 11:35 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-ppx-yojson-conv-lib): New variable.

Change-Id: Ifd7d64e88dc873bff08ac393779ecc86594455a1
---
 gnu/packages/ocaml.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 53909fe1e1..dc82739643 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6083,6 +6083,29 @@  (define-public ocaml-yojson
 serializers and deserializers from type definitions.")
     (license license:bsd-3)))
 
+(define-public ocaml-ppx-yojson-conv-lib
+  (package
+    (name "ocaml-ppx-yojson-conv-lib")
+    (version "0.16.0")
+    (home-page "https://github.com/janestreet/ppx_yojson_conv_lib")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+          (url home-page)
+          (commit (string-append "v" version))))
+        (sha256
+         (base32
+          "1npc1dbrcl3izi2rpf3rqz98jvsxrgzqn2vb95nf8wxgmh6gmrsc"))))
+    (build-system dune-build-system)
+    (propagated-inputs (list ocaml-yojson))
+    (properties `((upstream-name . "ppx_yojson_conv_lib")))
+    (synopsis "Runtime library used by ocaml PPX yojson convertor")
+    (description "Ppx_yojson_conv_lib is the runtime library used by
+ppx_yojson_conv, a ppx rewriter that can be used to convert ocaml types
+to a Yojson.Safe value.")
+    (license license:expat)))
+
 (define-public ocaml-merlin-lib
   (package
     (name "ocaml-merlin-lib")