diff mbox series

[bug#64209,v4,09/11] gnu: Add ocamlformat-rpc-lib.

Message ID 0be0b2f6d0ec32439f60adb1802d547e726d2ec2.1711236338.git.benjamin@uvy.fr
State New
Headers show
Series Update with rebase on master | expand

Commit Message

Benjamin March 23, 2024, 11:35 p.m. UTC
* gnu/packages/ocaml.scm (ocamlformat-rpc-lib): New variable.

Change-Id: If936fc70e541c5bf93bb021d8cc9f770b2d5329d
---
 gnu/packages/ocaml.scm | 12 ++++++++++++
 1 file changed, 12 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 120fe4eec8..953b563563 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8931,6 +8931,18 @@  (define-public ocamlformat
 a uniform style.")
     (license license:expat)))
 
+(define-public ocamlformat-rpc-lib
+  (package
+    (inherit ocamlformat)
+    (name "ocamlformat-rpc-lib")
+    (arguments
+     '(#:package "ocamlformat-rpc-lib"))
+    (propagated-inputs (list ocaml-csexp ocaml-odoc))
+    (synopsis "Auto-formatter for OCaml code in RPC mode")
+    (description
+     "OCamlFormat is a tool to automatically format OCaml code in a uniform style.
+This package defines a RPC interface to OCamlFormat.")))
+
 (define-public ocaml-bigstringaf
   (package
     (name "ocaml-bigstringaf")