diff mbox series

[bug#64209,v4,04/11] gnu: Add ocaml-xdg.

Message ID 71b4cc1dfa2e69259d781ba0d804f15b1a059de5.1711236338.git.benjamin@uvy.fr
State New
Headers show
Series Update with rebase on master | expand

Commit Message

Benjamin March 23, 2024, 11:35 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-xdg): New variable.

Change-Id: I88bc2fd7bb55d721ce1887a727480338dea0590c
---
 gnu/packages/ocaml.scm | 15 +++++++++++++++
 1 file changed, 15 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 7aa4b45374..0d77d93a34 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8765,6 +8765,21 @@  (define-public ocaml-dune-build-info
 reporting the version from the version control system during development to
 get an precise reference of when the executable was built.")))
 
+(define-public ocaml-xdg
+  (package
+    (inherit dune-ordering)
+    (name "ocaml-xdg")
+    (build-system dune-build-system)
+    (arguments
+     '(#:package "xdg"
+       ;; Tests have a cyclic dependency on stdune
+       #:tests? #f))
+    (propagated-inputs (list ocaml-odoc))
+    (synopsis "XDG Base Directory Specification library for ocaml")
+    (description
+     "This ocaml library returns user XDG directories such as XDG_CONFIG_HOME,
+     XDG_STATE_HOME.")))
+
 (define-public ocaml-either
   (package
     (name "ocaml-either")