diff mbox series

[bug#64209,v4,11/11] gnu: Add ocaml-lsp-server.

Message ID c824ece91a2fa3735a2463bfe79b7e31b238c770.1711236338.git.benjamin@uvy.fr
State New
Headers show
Series Update with rebase on master | expand

Commit Message

Benjamin March 23, 2024, 11:35 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-lsp-server): New variable.

Change-Id: Ib861dea3d7d00d570f253ffc3b4955e547dc2676
---
 gnu/packages/ocaml.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index bb7fd3a2de..cefb3384b5 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6228,6 +6228,48 @@  (define-public ocaml5.0-merlin
 Atom.")
      (license license:expat))))
 
+(define-public ocaml-lsp-server
+  (package
+    (name "ocaml-lsp-server")
+    (version "1.17.0")
+    (home-page "https://github.com/ocaml/ocaml-lsp")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                (url home-page)
+                (commit version)))
+              (sha256
+               (base32
+                "1w1m2mi7va3wcwgvgzqd3af6hrhx5zzyr3hqa228pcimp44w6f0h"))))
+    (build-system dune-build-system)
+    (arguments '(#:tests? #f)) ; tests are failing for v1.17
+    (propagated-inputs (list
+                             ocaml-re
+                             ocaml-ppx-yojson-conv-lib
+                             dune-rpc
+                             ocaml-chrome-trace
+                             dune-dyn
+                             dune-stdune
+                             ocaml-fiber
+                             ocaml-xdg
+                             dune-ordering
+                             ocaml-dune-build-info
+                             ocaml-spawn
+                             ocamlc-loc
+                             ocaml-uutf
+                             ocaml-pp
+                             ocaml-csexp
+                             ocamlformat-rpc-lib
+                             ocaml-odoc
+                             ocaml-merlin-lib))
+    (native-inputs (list ocaml-ppx-expect ocamlformat))
+    (properties `((upstream-name . "ocaml-lsp-server")))
+    (synopsis "LSP Server for OCaml")
+    (description "This package implements an Ocaml language server implementation.")
+    (license license:isc)))
+
+(define-public ocaml5.0-lsp-server (package-with-ocaml5.0 ocaml-lsp-server))
+
 (define-public ocaml-gsl
   (package
     (name "ocaml-gsl")