diff mbox series

[bug#64066,11/19] gnu: Add ghc-commutative-semigroup

Message ID c643ad36494d7f70e7940be3b93ecf9e6b4c6ab6.1686746569.git.zamfofex@twdb.moe
State New
Headers show
Series Add Plunder | expand

Commit Message

zamfofex June 14, 2023, 12:48 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-commutative-semigroup): New
variable.
---
 gnu/packages/haskell-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index bd6a999357..7f9380d959 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13147,6 +13147,25 @@  (define-public ghc-unordered-containers-bootstrap
     (native-inputs '())
     (properties '((hidden? #t)))))
 
+(define-public ghc-commutative-semigroups
+  (package
+    (name "ghc-commutative-semigroups")
+    (version "0.1.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (hackage-uri "commutative-semigroups" version))
+              (sha256
+               (base32
+                "1bmafx363gfsd9wwrf3xyrw9mnw6anmc1zdfv0p8597y4lxxach7"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "commutative-semigroups")))
+    (home-page "http://hackage.haskell.org/package/commutative-semigroups")
+    (synopsis "Commutative semigroups")
+    (description
+     "This package provides a commutative semigroup is a semigroup where the order of
+arguments to mappend does not matter.")
+    (license license:bsd-3)))
+
 (define-public ghc-unsafe
   (package
     (name "ghc-unsafe")