diff mbox series

[bug#64066,15/19] gnu: Add ghc-patch

Message ID a95fa50d0415004bb46779920ec9910d9149d15c.1686746569.git.zamfofex@twdb.moe
State New
Headers show
Series Add Plunder | expand

Commit Message

zamfofex June 14, 2023, 12:48 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-patch): New variable.
---
 gnu/packages/haskell-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index e21e32bae4..78cb1ccd39 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16580,6 +16580,40 @@  (define-public ghc-prim-uniq
 them as witnesses of type equality.")
     (license license:public-domain)))
 
+(define-public ghc-patch
+  (package
+    (name "ghc-patch")
+    (version "0.0.8.2")
+    (source (origin
+              (method url-fetch)
+              (uri (hackage-uri "patch" version))
+              (sha256
+               (base32
+                "15r2sjlpvp22iwd7qa1lqdq7n8nvqv2klvzrlm3phqq3j5n5x5y5"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "patch")))
+    (inputs (list ghc-constraints-extras
+                  ghc-commutative-semigroups
+                  ghc-dependent-map
+                  ghc-dependent-sum
+                  ghc-lens
+                  ghc-indexed-traversable
+                  ghc-semigroupoids
+                  ghc-witherable
+                  ghc-these
+                  ghc-semialign
+                  ghc-monoidal-containers))
+    (native-inputs (list ghc-hedgehog ghc-hunit ghc-filemanip hlint))
+    (home-page "https://obsidian.systems")
+    (synopsis
+     "Data structures for describing changes to other data structures.")
+    (description
+     "Data structures for describing changes to other data structures. .  In this
+library, a patch is something which can be applied, analogous to a function, and
+which distinguishes returning the argument it was provided from returning
+something else.")
+    (license license:bsd-3)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar