diff mbox series

[bug#64066,02/19] gnu: Add ghc-hscolour

Message ID bbe879de89552d76a78d088f0fe4e1afb7eff4ac.1686746568.git.zamfofex@twdb.moe
State New
Headers show
Series Add Plunder | expand

Commit Message

zamfofex June 14, 2023, 12:48 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-hscolour): New variable.
---
 gnu/packages/haskell-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index a819698710..2a4def30ff 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -32,6 +32,7 @@ 
 ;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;; Copyright © 2023 Josselin Poiret <dev@jpoiret.xyz>
+;;; Copyright © 2023 zamfofex <zamfofex@twdb.moe>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2047,6 +2048,27 @@  (define-public ghc-colour
 supported.  A module of colour names (\"Data.Colour.Names\") is provided.")
     (license license:expat)))
 
+(define-public ghc-hscolour
+  (package
+    (name "ghc-hscolour")
+    (version "1.24.4")
+    (source (origin
+              (method url-fetch)
+              (uri (hackage-uri "hscolour" version))
+              (sha256
+               (base32
+                "079jwph4bwllfp03yfr26s5zc6m6kw3nhb1cggrifh99haq34cr4"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "hscolour")))
+    (home-page "http://code.haskell.org/~malcolm/hscolour/")
+    (synopsis "Colourise Haskell code.")
+    (description
+     "hscolour is a small Haskell script to colourise Haskell code.  It currently has
+six output formats: ANSI terminal codes (optionally XTerm-256colour codes), HTML
+3.2 with <font> tags, HTML 4.01 with CSS, HTML 4.01 with CSS and mouseover
+annotations, XHTML 1.0 with inline CSS styling, LaTeX, and mIRC chat codes.")
+    (license license:lgpl2.1)))
+
 (define-public ghc-comonad
   (package
     (name "ghc-comonad")