diff mbox series

[bug#64066,13/19] gnu: Add ghc-dependent-map

Message ID aa210caafcb5b8a3fb0b5be9b769f56a2a266524.1686746569.git.zamfofex@twdb.moe
State New
Headers show
Series Add Plunder | expand

Commit Message

zamfofex June 14, 2023, 12:48 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-dependent-map): New variable.
---
 gnu/packages/haskell-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 06e7199c9c..48b259b41e 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13193,6 +13193,29 @@  (define-public ghc-dependent-sum
 dependent sum types by using your own \\\"tag\\\" types.")
     (license license:public-domain)))
 
+(define-public ghc-dependent-map
+  (package
+    (name "ghc-dependent-map")
+    (version "0.4.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (hackage-uri "dependent-map" version))
+              (sha256
+               (base32
+                "0b0zhyl3wkl4kkrxvq7vwjz3gn0ndxjjgyw9cky8a6xyv190pkjk"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "dependent-map")))
+    (inputs (list ghc-dependent-sum ghc-constraints-extras))
+    (arguments
+     `(#:cabal-revision ("1"
+                         "160p9crvlx1sn60inkwxa6mv1h2d4fgqnpsb2km67zrkpdfyd2s2")))
+    (home-page "https://github.com/obsidiansystems/dependent-map")
+    (synopsis "Dependent finite maps (partial dependent products)")
+    (description
+     "This package provides a type called @@DMap@@ which generalizes @@Data.Map.Map@@,
+allowing keys to specify the type of value that can be associated with them.")
+    (license #f)))
+
 (define-public ghc-unsafe
   (package
     (name "ghc-unsafe")