mbox series

[bug#64066,00/19] Add Plunder

Message ID cover.1686746568.git.zamfofex@twdb.moe
Headers show
Series Add Plunder | expand

Message

zamfofex June 14, 2023, 12:46 p.m. UTC
This patch set adds Plunder, a work-in-progress game, alongside various Haskell packages that it depends on.

zamfofex (19):
  gnu: Add ghc-proctest
  gnu: Add ghc-hscolour
  gnu: Add ghc-constraints-extras
  gnu: Add ghc-indexed-profunctors
  gnu: Add ghc-generic-lens-core
  gnu: Add ghc-generic-lens
  gnu: Add ghc-these-lens
  gnu: Add ghc-sdl2-ttf
  gnu: Add ghc-sdl2-gfx
  gnu: Add ghc-exception-transformers
  gnu: Add ghc-commutative-semigroup
  gnu: Add ghc-dependent-sum
  gnu: Add ghc-dependent-map
  gnu: Add ghc-prim-uniq
  gnu: Add ghc-patch
  gnu: Add ghc-ref-tf
  gnu: Add ghc-reflex
  gnu: Add ghc-reflex-sdl2
  gnu: Add Plunder

 gnu/packages/games.scm         |  42 +++-
 gnu/packages/haskell-check.scm |  23 ++
 gnu/packages/haskell-xyz.scm   | 446 +++++++++++++++++++++++++++++++++
 3 files changed, 510 insertions(+), 1 deletion(-)


base-commit: f598f5b870462afbb5a5770c1b16071bca63fc52

Comments

Liliana Marie Prikler June 14, 2023, 4:49 p.m. UTC | #1
Am Mittwoch, dem 14.06.2023 um 09:46 -0300 schrieb zamfofex:
> This patch set adds Plunder, a work-in-progress game, alongside
> various Haskell packages that it depends on.
> 
> zamfofex (19):
>   gnu: Add ghc-proctest
>   gnu: Add ghc-hscolour
>   gnu: Add ghc-constraints-extras
>   gnu: Add ghc-indexed-profunctors
>   gnu: Add ghc-generic-lens-core
>   gnu: Add ghc-generic-lens
>   gnu: Add ghc-these-lens
>   gnu: Add ghc-sdl2-ttf
>   gnu: Add ghc-sdl2-gfx
>   gnu: Add ghc-exception-transformers
>   gnu: Add ghc-commutative-semigroup
>   gnu: Add ghc-dependent-sum
>   gnu: Add ghc-dependent-map
>   gnu: Add ghc-prim-uniq
>   gnu: Add ghc-patch
>   gnu: Add ghc-ref-tf
>   gnu: Add ghc-reflex
>   gnu: Add ghc-reflex-sdl2
We prefer full sentences, including the period at the end. 
/etc/committer.scm and the included snippets ought to do the right
thing.
>   gnu: Add Plunder
Use the package name :)

I haven't looked at the packages themselves, but provided that CI
builds them fine, they're probably good to go.

Cheers
Ludovic Courtès July 7, 2023, 1:34 p.m. UTC | #2
Hello!

zamfofex <zamfofex@twdb.moe> skribis:

>   gnu: Add ghc-proctest
>   gnu: Add ghc-hscolour
>   gnu: Add ghc-constraints-extras
>   gnu: Add ghc-indexed-profunctors
>   gnu: Add ghc-generic-lens-core
>   gnu: Add ghc-generic-lens
>   gnu: Add ghc-these-lens
>   gnu: Add ghc-sdl2-ttf
>   gnu: Add ghc-sdl2-gfx
>   gnu: Add ghc-exception-transformers
>   gnu: Add ghc-commutative-semigroup
>   gnu: Add ghc-dependent-sum
>   gnu: Add ghc-dependent-map
>   gnu: Add ghc-prim-uniq
>   gnu: Add ghc-patch
>   gnu: Add ghc-ref-tf
>   gnu: Add ghc-reflex
>   gnu: Add ghc-reflex-sdl2
>   gnu: Add Plunder

I pushed the series as commit 849f31d5746f5633f9f2a768b76739afc257ae99.

I manually edited synopses and descriptions to follow the guidelines at
<https://guix.gnu.org/manual/devel/en/html_node/Synopses-and-Descriptions.html>
(‘guix lint’ would report most of the issues.)  In particular, many
would read “@@xyz@@” instead of “@code{xyz}”, maybe something to fix in
the importer?

There was also one package with (license #f) that I fixed.

In the future please make sure to check these things beforehand to
make the review process smoother!

Thanks,
Ludo’.