diff mbox series

[bug#64066,14/19] gnu: Add ghc-prim-uniq

Message ID 49cf4393e8e6ecf91e73b87fcba71c02d574e948.1686746569.git.zamfofex@twdb.moe
State New
Headers show
Series Add Plunder | expand

Commit Message

zamfofex June 14, 2023, 12:48 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-prim-uniq): New variable.
---
 gnu/packages/haskell-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 48b259b41e..e21e32bae4 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16560,6 +16560,26 @@  (define-public ghc-test-framework-leancheck
 to incorporate LeanCheck tests into test-framework test suites.")
     (license license:bsd-3)))
 
+(define-public ghc-prim-uniq
+  (package
+    (name "ghc-prim-uniq")
+    (version "0.2")
+    (source (origin
+              (method url-fetch)
+              (uri (hackage-uri "prim-uniq" version))
+              (sha256
+               (base32
+                "1l7jlv3pfasn89n2wpgff972npy423vqsidkkn5crxfyqjyzxbdv"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "prim-uniq")))
+    (inputs (list ghc-dependent-sum ghc-primitive))
+    (home-page "https://github.com/obsidiansystems/prim-uniq")
+    (synopsis "Opaque unique identifiers in primitive state monads")
+    (description
+     "Opaque unique identifiers in primitive state monads and a GADT-like type using
+them as witnesses of type equality.")
+    (license license:public-domain)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar