[bug#75966,v3,02/10] gnu: calibre: Do not wrap with QTWEBENGINEPROCESS_PATH.

Message ID c29bb9157b159b0bb364f501dee62d35343b9e91.1738470835.git.iyzsong@member.fsf.org
State New
Headers
Series [bug#75966,v3,01/10] gnu: qtwebengine: Fix default path for QtWebEngineProcess. |

Commit Message

vasilii.smirnov--- via Guix-patches" via Feb. 2, 2025, 4:34 a.m. UTC
  From: 宋文武 <iyzsong@member.fsf.org>

* gnu/packages/ebook.scm (calibre)[arguments]: Remove 'wrap-program phase.

Change-Id: If289d6d5bcd1582134bbb02a179425a4f9c6a4d0
---
 gnu/packages/ebook.scm | 21 +--------------------
 1 file changed, 1 insertion(+), 20 deletions(-)
  

Comments

Maxim Cournoyer Feb. 3, 2025, 2:40 p.m. UTC | #1
iyzsong@envs.net writes:

> From: 宋文武 <iyzsong@member.fsf.org>
>
> * gnu/packages/ebook.scm (calibre)[arguments]: Remove 'wrap-program phase.
>
> Change-Id: If289d6d5bcd1582134bbb02a179425a4f9c6a4d0

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
  

Patch

diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 0cd2b31724..73fea2f66a 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -320,26 +320,7 @@  (define-public calibre
                      (string-append #$(this-package-input "font-liberation")
                                     "/share/fonts/truetype")))
                 (delete-file-recursively font-dest)
-                (symlink font-src font-dest))))
-          ;; Make run-time dependencies available to the binaries.
-          (add-after 'wrap 'wrap-program
-            (lambda* (#:key inputs #:allow-other-keys)
-              (with-directory-excursion (string-append #$output "/bin")
-                (for-each
-                 (lambda (binary)
-                   (wrap-program binary
-                     ;; Make QtWebEngineProcess available.
-                     `("QTWEBENGINEPROCESS_PATH" =
-                       ,(list
-                         (search-input-file
-                          inputs "/lib/qt5/libexec/QtWebEngineProcess")))))
-                 ;; Wrap all the binaries shipping with the package, except
-                 ;; for the wrappings created during the 'wrap standard
-                 ;; phase.  This extends existing .calibre-real wrappers
-                 ;; rather than create ..calibre-real-real-s.  For more
-                 ;; information see: https://issues.guix.gnu.org/43249.
-                 (find-files "." (lambda (file stat)
-                                   (not (wrapped-program? file)))))))))))
+                (symlink font-src font-dest)))))))
     (home-page "https://calibre-ebook.com/")
     (synopsis "E-book library management software")
     (description "Calibre is an e-book library manager.  It can view, convert