[bug#75966,v3,09/10] gnu: kiwix-desktop: Do not wrap with QTWEBENGINEPROCESS_PATH.
Commit Message
From: 宋文武 <iyzsong@member.fsf.org>
* gnu/packages/web.scm (kiwix-desktop):[arguments]: Remove
'wrap-qt-process-path phase.
Change-Id: Iaf33c180268358a3b1bf1695b37313f20b410f9d
---
gnu/packages/web.scm | 10 +---------
1 file changed, 1 insertion(+), 9 deletions(-)
@@ -9404,15 +9404,7 @@ (define-public kiwix-desktop
(lambda* (#:key outputs #:allow-other-keys)
(invoke "qmake"
(string-append "PREFIX="
- (assoc-ref outputs "out")))))
- (add-after 'install 'wrap-qt-process-path
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin/kiwix-desktop"))
- (qt-process-path (search-input-file
- inputs "/lib/qt5/libexec/QtWebEngineProcess")))
- (wrap-program bin
- `("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))))))))
+ (assoc-ref outputs "out"))))))))
(inputs
(list bash-minimal
curl