[bug#75966,v3,10/10] gnu: qutebrowser: Do not wrap with QTWEBENGINEPROCESS_PATH.
Commit Message
From: 宋文武 <iyzsong@member.fsf.org>
* gnu/packages/web-browsers.scm (qutebrowser): [arguments]: Remove
QTWEBENGINEPROCESS_PATH from the 'wrap-qt-process-path phase.
Change-Id: I7227e1f5abd9e9db98d603ca74ece6ea268b7eaa
---
gnu/packages/web-browsers.scm | 7 ++-----
1 file changed, 2 insertions(+), 5 deletions(-)
Comments
Hi,
iyzsong@envs.net writes:
> From: 宋文武 <iyzsong@member.fsf.org>
>
> * gnu/packages/web-browsers.scm (qutebrowser): [arguments]: Remove
> QTWEBENGINEPROCESS_PATH from the 'wrap-qt-process-path phase.
>
[...]
This one and the other before LGTM, with the same nitpicks about the GNU
change log style.
--8<---------------cut here---------------start------------->8---
Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
--8<---------------cut here---------------end--------------->8---
By the way, I notice that sending the cover letter on each submission is
useful, as I could then put my reviewed-by trailer on the 0/N commit
(the cover letter) to mean 'whole series LGTM', at least per 'b4 shazam'
semantic, which will add the trailer for you if you use it to apply the
patches.
--
Thanks,
Maxim
@@ -492,7 +492,7 @@ (define-public qutebrowser
python-pyqtwebengine-6
python-tldextract
;; While qtwebengine is provided by python-pyqtwebengine-6, it's
- ;; included here so we can wrap QTWEBENGINEPROCESS_PATH.
+ ;; included here so we can wrap QTWEBENGINE_RESOURCES_PATH.
qtwebengine))
(arguments
`(;; FIXME: With the existence of qtwebengine, tests can now run. But
@@ -547,10 +547,7 @@ (define-public qutebrowser
(wrap-program (search-input-file outputs "bin/qutebrowser")
`("QTWEBENGINE_RESOURCES_PATH" =
(,(search-input-directory
- inputs "/share/qt6/resources")))
- `("QTWEBENGINEPROCESS_PATH" =
- (,(search-input-file
- inputs "/lib/qt6/libexec/QtWebEngineProcess")))))))))
+ inputs "/share/qt6/resources")))))))))
(home-page "https://qutebrowser.org/")
(synopsis "Minimal, keyboard-focused, vim-like web browser")
(description "qutebrowser is a keyboard-focused browser with a minimal