[bug#75966,v3,07/10] gnu: openshot: Do not wrap with QTWEBENGINEPROCESS_PATH.
Commit Message
From: 宋文武 <iyzsong@member.fsf.org>
* gnu/packages/video.scm (openshot)[arguments]: Remove 'wrap-program phase.
Change-Id: Id09d18cb0f2f9e6542cdeeaa3026a0ff71164121
---
gnu/packages/video.scm | 14 +-------------
1 file changed, 1 insertion(+), 13 deletions(-)
@@ -6049,19 +6049,7 @@ (define-public openshot
(lambda _
;; src/classes/info.py "needs" to create several
;; directories in $HOME when loaded during build
- (setenv "HOME" "/tmp")))
- (add-after 'install 'wrap-program
- (lambda* (#:key outputs inputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (qtwebengine-process-path
- (search-input-file
- inputs "/lib/qt5/libexec/QtWebEngineProcess")))
- (wrap-qt-program "openshot-qt"
- #:output out #:inputs inputs)
- ;; Help the program discover QtWebEngine at runtime.
- (wrap-program (string-append out "/bin/openshot-qt")
- `("QTWEBENGINEPROCESS_PATH" =
- (,qtwebengine-process-path)))))))))
+ (setenv "HOME" "/tmp"))))))
(home-page "https://www.openshot.org/")
(synopsis "Video editor")
(description "OpenShot takes your videos, photos, and music files and