[bug#75966,v3,03/10] gnu: anki: Do not wrap with QTWEBENGINEPROCESS_PATH.

Message ID 3ab14499f91127ac45500e86ce6a4d71772e60a8.1738470835.git.iyzsong@member.fsf.org
State New
Headers
Series [bug#75966,v3,01/10] gnu: qtwebengine: Fix default path for QtWebEngineProcess. |

Commit Message

vasilii.smirnov--- via Guix-patches" via Feb. 2, 2025, 4:34 a.m. UTC
  From: 宋文武 <iyzsong@member.fsf.org>

* gnu/packages/education.scm (anki):[arguments]: Remove
QTWEBENGINEPROCESS_PATH from the 'wrap phase.

Change-Id: If8b2cd5bcb0624033b6f7a29c9b865b70943032d
---
 gnu/packages/education.scm | 13 +++----------
 1 file changed, 3 insertions(+), 10 deletions(-)
  

Comments

Maxim Cournoyer Feb. 3, 2025, 2:42 p.m. UTC | #1
Hi,

iyzsong@envs.net writes:

> From: 宋文武 <iyzsong@member.fsf.org>
>
> * gnu/packages/education.scm (anki):[arguments]: Remove
> QTWEBENGINEPROCESS_PATH from the 'wrap phase.

nitpick: You can omit single quotes for phase names in the change log,
and there shouldn't be a colon between (anki) and [arguments] (there
should be a space according to (info '(standards) Style of Change Logs')
which is a manual provided the autoconf package.).

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>
  

Patch

diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index f42a216972..f0c0e931bf 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -836,18 +836,11 @@  (define-public anki
                          (filter (match-lambda
                                    ((label . _)
                                     (string-prefix? "python-" label)))
-                                 inputs)))
-                   (qtwebengineprocess
-                    (search-input-file inputs
-                                       "lib/qt5/libexec/QtWebEngineProcess")))
-               ;; The program fails to find the QtWebEngineProcess program, so
-               ;; we set QTWEBENGINEPROCESS_PATH to help it.  PYTHONPATH is
-               ;; wrapped to avoid declaring Python libraries as propagated
-               ;; inputs.
+                                 inputs))))
+               ;; PYTHONPATH is wrapped to avoid declaring Python libraries as
+               ;; propagated inputs.
                (for-each (lambda (program)
                            (wrap-program program
-                             `("QTWEBENGINEPROCESS_PATH" =
-                               (,qtwebengineprocess))
                              `("PATH" prefix (,(string-append
                                                 (assoc-ref inputs "mpv")
                                                 "/bin")))