[bug#75966,v3,03/10] gnu: anki: Do not wrap with QTWEBENGINEPROCESS_PATH.
Commit Message
From: 宋文武 <iyzsong@member.fsf.org>
* gnu/packages/education.scm (anki):[arguments]: Remove
QTWEBENGINEPROCESS_PATH from the 'wrap phase.
Change-Id: If8b2cd5bcb0624033b6f7a29c9b865b70943032d
---
gnu/packages/education.scm | 13 +++----------
1 file changed, 3 insertions(+), 10 deletions(-)
Comments
Hi,
iyzsong@envs.net writes:
> From: 宋文武 <iyzsong@member.fsf.org>
>
> * gnu/packages/education.scm (anki):[arguments]: Remove
> QTWEBENGINEPROCESS_PATH from the 'wrap phase.
nitpick: You can omit single quotes for phase names in the change log,
and there shouldn't be a colon between (anki) and [arguments] (there
should be a space according to (info '(standards) Style of Change Logs')
which is a manual provided the autoconf package.).
Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>
@@ -836,18 +836,11 @@ (define-public anki
(filter (match-lambda
((label . _)
(string-prefix? "python-" label)))
- inputs)))
- (qtwebengineprocess
- (search-input-file inputs
- "lib/qt5/libexec/QtWebEngineProcess")))
- ;; The program fails to find the QtWebEngineProcess program, so
- ;; we set QTWEBENGINEPROCESS_PATH to help it. PYTHONPATH is
- ;; wrapped to avoid declaring Python libraries as propagated
- ;; inputs.
+ inputs))))
+ ;; PYTHONPATH is wrapped to avoid declaring Python libraries as
+ ;; propagated inputs.
(for-each (lambda (program)
(wrap-program program
- `("QTWEBENGINEPROCESS_PATH" =
- (,qtwebengineprocess))
`("PATH" prefix (,(string-append
(assoc-ref inputs "mpv")
"/bin")))