diff mbox series

[bug#64711,36/43] gnu: guile-git: Skip http proxy test on the Hurd.

Message ID b2204774a82b7cb4695e2aaf9bf7582ebca8a0b8.1689690897.git.janneke@gnu.org
State New
Headers show
Series Fix builds and skip failing tests for the Hurd. | expand

Commit Message

Janneke Nieuwenhuizen July 18, 2023, 2:40 p.m. UTC
* gnu/packages/guile.scm (guile-git)[arguments]: When building natively on the
Hurd, add phase 'skip-tests/hurd'.
---
 gnu/packages/guile.scm | 15 ++++++++++++++-
 1 file changed, 14 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index ed20c1dfbc..e9bed75fb1 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -838,7 +838,20 @@  (define-public guile-git
                  (lambda _
                    (substitute* "Makefile.am"
                      ((".*tests/blob\\.scm.*") ""))))))
-           '())))
+           '())
+       ,@(if (system-hurd?)
+             (list
+              #:phases
+              #~(modify-phases %standard-phases
+                  (add-after 'unpack 'skip-tests/hurd
+                    (lambda _
+                      (substitute* "tests/proxy.scm"
+                        (("\\(test-begin.*" all)
+                         (string-append
+                          all
+                          "(when (string-ci= \"GNU\" (vector-ref (uname) 0))\n"
+                          "  (test-skip 1))\n")))))))
+             '())))
     (native-inputs
      (list pkg-config autoconf automake texinfo guile-3.0 guile-bytestructures))
     (inputs