diff mbox series

[bug#64711,39/43] gnu: harfbuzz: Support build for the Hurd.

Message ID 9fc9a0ae11de8c4484558c0cbac047330ca909f6.1689690897.git.janneke@gnu.org
State New
Headers show
Series Fix builds and skip failing tests for the Hurd. | expand

Commit Message

Janneke Nieuwenhuizen July 18, 2023, 2:40 p.m. UTC
* gnu/packages/gtk.scm (harfbuzz)[native-inputs]: Do not include
gobject-introspection when building for the Hurd.
---
 gnu/packages/gtk.scm | 12 +++++++-----
 1 file changed, 7 insertions(+), 5 deletions(-)

Comments

Maxim Cournoyer July 18, 2023, 8:13 p.m. UTC | #1
Hi,

Janneke Nieuwenhuizen <janneke@gnu.org> writes:

> * gnu/packages/gtk.scm (harfbuzz)[native-inputs]: Do not include
> gobject-introspection when building for the Hurd.
> ---
>  gnu/packages/gtk.scm | 12 +++++++-----
>  1 file changed, 7 insertions(+), 5 deletions(-)
>
> diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
> index eb69a88221..853696c7f5 100644
> --- a/gnu/packages/gtk.scm
> +++ b/gnu/packages/gtk.scm
> @@ -276,11 +276,13 @@ (define-public harfbuzz
>       ;; There are all in the Requires or Requires.private field of '.pc'.
>       (list glib graphite2 icu4c))
>      (native-inputs
> -     (list `(,glib "bin")               ;for glib-mkenums
> -           gobject-introspection
> -           pkg-config
> -           python-wrapper
> -           which))
> +     `((,glib "bin")               ;for glib-mkenums
> +       ,@(if (target-hurd?)
> +             '()
> +             (list gobject-introspection))
> +       ,pkg-config
> +       ,python-wrapper
> +       ,which))

Here also (basically when it's touching label-free inputs), I'd use
append with a conditional to avoid the unquote noise.

Otherwise LGTM.
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index eb69a88221..853696c7f5 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -276,11 +276,13 @@  (define-public harfbuzz
      ;; There are all in the Requires or Requires.private field of '.pc'.
      (list glib graphite2 icu4c))
     (native-inputs
-     (list `(,glib "bin")               ;for glib-mkenums
-           gobject-introspection
-           pkg-config
-           python-wrapper
-           which))
+     `((,glib "bin")               ;for glib-mkenums
+       ,@(if (target-hurd?)
+             '()
+             (list gobject-introspection))
+       ,pkg-config
+       ,python-wrapper
+       ,which))
     (arguments
      (list #:configure-flags
            #~(list "--with-graphite2"