diff mbox series

[bug#64711,04/43] gnu: grep: Update hanging and failing tests on the Hurd.

Message ID 30ff4538c1f67249b2720dcef60877b9a7cab7ad.1689690897.git.janneke@gnu.org
State New
Headers show
Series Fix builds and skip failing tests for the Hurd. | expand

Commit Message

Janneke Nieuwenhuizen July 18, 2023, 2:39 p.m. UTC
* gnu/packages/base.scm (grep)[arguments]: When building natively on the Hurd,
remove Rename phase 'skip-triple-backref-test' to 'skip-tests'.  Remove
"tests/triple-backref" as it now passes.  Add the hanging
"tests/hash-collision-perf" test, and the failing "tests/file" test.
---
 gnu/packages/base.scm | 24 ++++++++++--------------
 1 file changed, 10 insertions(+), 14 deletions(-)

Comments

Ludovic Courtès July 18, 2023, 8:23 p.m. UTC | #1
Janneke Nieuwenhuizen <janneke@gnu.org> skribis:

> * gnu/packages/base.scm (grep)[arguments]: When building natively on the Hurd,
> remove Rename phase 'skip-triple-backref-test' to 'skip-tests'.  Remove
> "tests/triple-backref" as it now passes.  Add the hanging
> "tests/hash-collision-perf" test, and the failing "tests/file" test.

[...]

> +              '((add-before 'check 'skip-test
>                    (lambda _
> -                    ;; This test is marked as malfunctioning on glibc systems
> -                    ;; due to
> -                    ;; <https://sourceware.org/bugzilla/show_bug.cgi?id=11053>
> -                    ;; and it triggers a segfault with glibc 2.33 on GNU/Hurd.
> -                    ;; Skip it.
> -                    (substitute* "tests/triple-backref"
> -                      (("^warn_" all)
> -                       (string-append "exit 77\n" all))))))
> -              '()))
> -      #:make-flags ,(if (target-hurd?)
> -                        ''("XFAIL_TESTS=test-perror2 equiv-classes") ;XXX
> -                        ''())))
> +                    (substitute*
> +                        ;; This test hangs
> +                        '("tests/hash-collision-perf"
> +                          ;; This test fails
> +                          "tests/file")
> +                      (("^#!.*" all)
> +                       (string-append all "exit 77;\n"))))))

Are there any hints in the log files of these two tests?

Contrary to Coreutils, this is less likely to be an environment issue—or
if it is, that might be clear from the log.  So having an idea of what’s
failing and ideally a reference to a bug report upstream would be great.
Maybe not a blocker, but something we should do.

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index e941853d20..f1b027b0dc 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -134,21 +134,17 @@  (define-public grep
                                  (string-append bin "/fgrep"))
                 (("^exec grep")
                  (string-append "exec " bin "/grep"))))))
-        ,@(if (target-hurd?)
-              '((add-before 'check 'skip-triple-backref-test
+        ,@(if (system-hurd?)
+              '((add-before 'check 'skip-test
                   (lambda _
-                    ;; This test is marked as malfunctioning on glibc systems
-                    ;; due to
-                    ;; <https://sourceware.org/bugzilla/show_bug.cgi?id=11053>
-                    ;; and it triggers a segfault with glibc 2.33 on GNU/Hurd.
-                    ;; Skip it.
-                    (substitute* "tests/triple-backref"
-                      (("^warn_" all)
-                       (string-append "exit 77\n" all))))))
-              '()))
-      #:make-flags ,(if (target-hurd?)
-                        ''("XFAIL_TESTS=test-perror2 equiv-classes") ;XXX
-                        ''())))
+                    (substitute*
+                        ;; This test hangs
+                        '("tests/hash-collision-perf"
+                          ;; This test fails
+                          "tests/file")
+                      (("^#!.*" all)
+                       (string-append all "exit 77;\n"))))))
+              '()))))
    (synopsis "Print lines matching a pattern")
    (description
      "grep is a tool for finding text inside files.  Text is found by