diff mbox series

[bug#64711,37/43] gnu: glib: Disable tests for the Hurd.

Message ID ac66fb4e8ea35e1965bc2fab1e0673fd438f2294.1689690897.git.janneke@gnu.org
State New
Headers show
Series Fix builds and skip failing tests for the Hurd. | expand

Commit Message

Janneke Nieuwenhuizen July 18, 2023, 2:40 p.m. UTC
* gnu/packages/glib.scm (glib)[arguments]: When building for the Hurd,
set #:tests? to #false.
---
 gnu/packages/glib.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Liliana Marie Prikler July 18, 2023, 3:56 p.m. UTC | #1
Am Dienstag, dem 18.07.2023 um 16:40 +0200 schrieb Janneke
Nieuwenhuizen:
> * gnu/packages/glib.scm (glib)[arguments]: When building for the
> Hurd,
> set #:tests? to #false.
> ---
>  gnu/packages/glib.scm | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
> index e988e8dc87..bcbc1f22b1 100644
> --- a/gnu/packages/glib.scm
> +++ b/gnu/packages/glib.scm
> @@ -14,7 +14,7 @@
>  ;;; Copyright © 2019, 2020, 2021 Marius Bakke <marius@gnu.org>
>  ;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
>  ;;; Copyright © 2020 Florian Pelz <pelzflorian@pelzflorian.de>
> -;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
> +;;; Copyright © 2020, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
>  ;;; Copyright © 2020 Arthur Margerit <ruhtra.mar@gmail.com>
>  ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
>  ;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
> @@ -241,6 +241,7 @@ (define glib
>                 "debug"))
>      (arguments
>       (list
> +      #:tests? (not (target-hurd?))
>        #:disallowed-references
>        (cons tzdata-for-tests
>              ;; Verify glib-mkenums, gtester, ... use the cross-
> compiled
Instead of disabling tests altogether, can we just disable those that
fail on the Hurd?
Janneke Nieuwenhuizen July 18, 2023, 4:32 p.m. UTC | #2
Liliana Marie Prikler writes:

> Am Dienstag, dem 18.07.2023 um 16:40 +0200 schrieb Janneke
> Nieuwenhuizen:
>> * gnu/packages/glib.scm (glib)[arguments]: When building for the
>> Hurd,
>> set #:tests? to #false.

[..]
>> +      #:tests? (not (target-hurd?))

>> compiled

> Instead of disabling tests altogether, can we just disable those that
> fail on the Hurd?

We probably can, and I have tried to do so in most cases.  However,
identifying those tests can be quite time consuming.  I'm not sure how
many tests failed here, and note that some tests will hang or crash the
Hurd, so if we decide to do this, I would appreciate some help :-)

Ludo on the other hand, argued against having more than ~20 (IIRC) test
exceptions and using #:tests? #f instead.

My idea was to get guix to build natively, and guix pull to work.  Once
we get those to work, we can possibly look forward to more contributors
to this.

Greetings,
Janneke
Maxim Cournoyer July 18, 2023, 8:05 p.m. UTC | #3
Hello,

Janneke Nieuwenhuizen <janneke@gnu.org> writes:

> Liliana Marie Prikler writes:
>
>> Am Dienstag, dem 18.07.2023 um 16:40 +0200 schrieb Janneke
>> Nieuwenhuizen:
>>> * gnu/packages/glib.scm (glib)[arguments]: When building for the
>>> Hurd,
>>> set #:tests? to #false.
>
> [..]
>>> +      #:tests? (not (target-hurd?))
>
>>> compiled
>
>> Instead of disabling tests altogether, can we just disable those that
>> fail on the Hurd?
>
> We probably can, and I have tried to do so in most cases.  However,
> identifying those tests can be quite time consuming.  I'm not sure how
> many tests failed here, and note that some tests will hang or crash the
> Hurd, so if we decide to do this, I would appreciate some help :-)
>
> Ludo on the other hand, argued against having more than ~20 (IIRC) test
> exceptions and using #:tests? #f instead.
>
> My idea was to get guix to build natively, and guix pull to work.  Once
> we get those to work, we can possibly look forward to more contributors
> to this.

I agree with Liliana that it's nicer to disable just these tests that
fail, but in light of what you wrote, your approach seems reasonable.
diff mbox series

Patch

diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index e988e8dc87..bcbc1f22b1 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -14,7 +14,7 @@ 
 ;;; Copyright © 2019, 2020, 2021 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
 ;;; Copyright © 2020 Florian Pelz <pelzflorian@pelzflorian.de>
-;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2020, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2020 Arthur Margerit <ruhtra.mar@gmail.com>
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
 ;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
@@ -241,6 +241,7 @@  (define glib
                "debug"))
     (arguments
      (list
+      #:tests? (not (target-hurd?))
       #:disallowed-references
       (cons tzdata-for-tests
             ;; Verify glib-mkenums, gtester, ... use the cross-compiled