diff mbox series

[bug#42297,03/10] gnu: Add python-minio.

Message ID a6cca7e3d3ecc2785c08092383108dab715febfb.1594321515.git.brown121407@posteo.ro
State New
Headers show
Series Add Python packages for Sourcehut | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Alexandru-Sergiu Marton July 9, 2020, 7:19 p.m. UTC
* gnu/packages/python-xyz.scm (python-minio): New variable.
---
 gnu/packages/python-xyz.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 98db6d9e51..5ce34cd738 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20472,3 +20472,36 @@  For the most part it's transliterated from C, the major differences are:
 @end itemize
 ")
     (license license:gpl3+)))
+
+(define-public python-minio
+  (package
+    (name "python-minio")
+    (version "5.0.10")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "minio" version))
+       (sha256
+        (base32
+         "05xl6ifzyvy8nnigv6267my8v9crlp7yl4nix4rng02zlcvpdjvf"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f)) ;; FIXME 4 tests fail
+    (propagated-inputs
+     `(("python-certifi" ,python-certifi)
+       ("python-configparser" ,python-configparser)
+       ("python-dateutil" ,python-dateutil)
+       ("python-future" ,python-future)
+       ("python-pytz" ,python-pytz)
+       ("python-urllib3" ,python-urllib3)))
+    (native-inputs
+     `(("python-nose" ,python-nose)
+       ("python-mock" ,python-mock)
+       ("python-faker" ,python-faker)))
+    (home-page "https://github.com/minio/minio-py")
+    (synopsis
+     "MinIO Python Library for Amazon S3 Compatible Cloud Storage for Python")
+    (description
+     "The MinIO Python Client SDK provides simple APIs to access any Amazon S3
+compatible object storage server.")
+    (license license:asl2.0)))