diff mbox series

[bug#42297,04/10] gnu: Add python-hglib.

Message ID 4345d5a5b07443a5bb91d656537096ba1ecd615f.1594321515.git.brown121407@posteo.ro
State New
Headers show
Series Add Python packages for Sourcehut | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Alexandru-Sergiu Marton July 9, 2020, 7:19 p.m. UTC
* gnu/packages/python-xyz.scm (python-hglib): New variable.
---
 gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5ce34cd738..c97f2bf331 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20505,3 +20505,29 @@  For the most part it's transliterated from C, the major differences are:
      "The MinIO Python Client SDK provides simple APIs to access any Amazon S3
 compatible object storage server.")
     (license license:asl2.0)))
+
+(define-public python-hglib
+  (package
+    (name "python-hglib")
+    (version "2.6.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "python-hglib" version))
+       (sha256
+        (base32
+         "1cm3din9j2xbgipnay5kgzlj6imsrs3lgc09hkndcb9k9p5s07vw"))))
+    (build-system python-build-system)
+    (arguments
+     ;; FIXME: Fails a lot of tests
+     `(#:tests? #f))
+    (propagated-inputs
+     `(("mercurial" ,mercurial)))
+    (native-inputs
+     `(("python-nose" ,python-nose)))
+    (home-page
+     "https://www.mercurial-scm.org/wiki/PythonHglib")
+    (synopsis "Mercurial Python library")
+    (description "A Python library for interfacing with Mercurial's
+CommandServer.")
+    (license license:expat)))