diff mbox series

[bug#42297,09/10] gnu: Add python-atpublic.

Message ID aa6bc572e9f612cc0b948d5f276eb8cce951d3fe.1594321515.git.brown121407@posteo.ro
State New
Headers show
Series Add Python packages for Sourcehut | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Alexandru-Sergiu Marton July 9, 2020, 7:19 p.m. UTC
* gnu/packages/python-xyz.scm (python-atpublic): New variable.
---
 gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4caf29169b..d8270edca1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20644,3 +20644,26 @@  features are:
 Currently ssh-rsa, ssh-dss (DSA), ssh-ed25519 and ecdsa keys with NIST
 curves are supported.")
     (license license:bsd-3)))
+
+(define-public python-atpublic
+  (package
+    (name "python-atpublic")
+    (version "1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "atpublic" version))
+       (sha256
+        (base32
+         "0i3sbxkdlbb4560rrlmwwd5y4ps7k73lp4d8wnmd7ag9k426gjkx"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f)) ;; FIXME
+    (home-page "https://gitlab.com/warsaw/public")
+    (synopsis
+     "Decorator for populating __all__")
+    (description
+     "This is a very simple decorator and function which populates a
+module's __all__ and optionally the module globals.  This provides
+both a pure-Python implementation and an optional C implementation.")
+    (license license:asl2.0)))