diff mbox series

[bug#42297,06/10] gnu: Add python-emailthreads.

Message ID cd51e808502c3b5db57f7ebc62627c6b44583830.1594321515.git.brown121407@posteo.ro
State New
Headers show
Series Add Python packages for Sourcehut | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Alexandru-Sergiu Marton July 9, 2020, 7:19 p.m. UTC
* gnu/packages/python-xyz.scm (python-emailthreads): New variable.
---
 gnu/packages/python-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 20abc1a9d3..b3dddc57c1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20552,3 +20552,33 @@  CommandServer.")
      "Unidiff is a simple Python library to parse and interact with unified
 diff data.")
     (license license:expat)))
+
+(define-public python-emailthreads
+  (package
+    (name "python-emailthreads")
+    (version "v0.1.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "emailthreads" version))
+       (sha256
+        (base32
+         "128by819l2awvs3gvlcs75s0k8lfl8420s9khjh8bfk8p780rlfm"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:modules ((guix build utils)
+                  (guix build python-build-system))
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'prepare-for-tests
+           (lambda _
+             (setenv "PKGVER" (version)))))))
+    (home-page
+     "https://github.com/emersion/python-emailthreads")
+    (synopsis
+     "Parses email threads into conversation trees")
+    (description
+     "Python library to parse and format email threads.  Give it a list
+of emails that are part of the same thread and it'll build a tree of
+responses to the original message.")
+    (license license:expat)))