diff mbox series

[bug#42297,01/10] gnu: Add hg-evolve.

Message ID 395cba14f2d2998dc300c547c884eddda2e39598.1594321515.git.brown121407@posteo.ro
State New
Headers show
Series Add Python packages for Sourcehut | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Alexandru-Sergiu Marton July 9, 2020, 7:19 p.m. UTC
* gnu/packages/version-control.scm (hg-evolve): New variable.
---
 gnu/packages/version-control.scm | 35 ++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 5151e63ee1..1f37623ee2 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -2517,3 +2517,38 @@  package is provided for users who need to recover @code{tla} repositories and
 for historians.")
     (home-page "https://www.gnu.org/software/gnu-arch/")
     (license license:gpl2)))                      ;version 2 only
+
+(define-public hg-evolve
+  (package
+    (name "hg-evolve")
+    (version "10.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "hg-evolve" version))
+       (sha256
+        (base32
+         "03kn1c62y6rb851wjhsaxkrwq223hkc4ij59i85999byyb2hyqad"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("mercurial" ,mercurial)))
+    (home-page
+     "https://www.mercurial-scm.org/doc/evolution/")
+    (synopsis
+     "Flexible evolution of Mercurial history")
+    (description
+     "This Mercurial provides faster and safer mutable history.  It
+implements the changeset evolution concept for Mercurial.
+
+@enumerate
+@item It offers a safe and simple way to refine changesets locally and
+propagate those changes to other repositories.
+@item It can automatically detect and handle the complex issues that can
+arise from exchanging draft changesets.
+@item It even makes it possible for multiple developers to safely rewrite
+the same parts of history in a distributed way.
+@item It fully respects the Phases concept so users will only be able to
+rewrite parts of the history that are safe to change.  Phases have been
+part of Mercurial since early 2012.
+@end enumerate\n")
+    (license license:gpl2+)))