diff mbox series

[bug#42297,02/10] gnu: Add python-pgpy.

Message ID 874f8136b19b7f04b0790a1e795beaef876de0a0.1594321515.git.brown121407@posteo.ro
State New
Headers show
Series Add Python packages for Sourcehut | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Alexandru-Sergiu Marton July 9, 2020, 7:19 p.m. UTC
* gnu/packages/python-crypto.scm (python-pgpy): New variable.
---
 gnu/packages/python-crypto.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 5c9c251c01..f91e1e0999 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1429,3 +1429,28 @@  can decide how long it takes to hash a password and how much memory is required.
 data such as API keys, cryptocurrency wallets, or seeds for digital
 signatures.")
     (license (list license:expat license:asl2.0)))) ; dual licensed
+
+(define-public python-pgpy
+  (package
+    (name "python-pgpy")
+    (version "0.5.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "PGPy" version))
+       (sha256
+        (base32
+         "0i4lqhzdwkjkim3wab0kqadx28z3r5ixlh6qxj4lif4gif56c0m7"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-cryptography" ,python-cryptography)
+       ("python-pyasn1" ,python-pyasn1)
+       ("python-six" ,python-six)))
+    (home-page
+     "https://github.com/SecurityInnovation/PGPy")
+    (synopsis "Pretty Good Privacy for Python")
+    (description
+     "PGPy is a Python (2 and 3) library for implementing Pretty Good
+Privacy into Python programs, conforming to the OpenPGP specification
+per RFC 4880.")
+    (license license:bsd-3)))