diff mbox series

[bug#66966,05/13] gnu: Add r-basics.

Message ID 3efcce969a7ed38c87dcb77b02ab2c551a1709b7.1699268809.git.madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#66966,01/13] gnu: Add r-breastcancervdx. | expand

Commit Message

Mădălin Ionel Patrașcu Nov. 6, 2023, 11:06 a.m. UTC
* gnu/packages/bioconductor.scm (r-basics): New variable.

Change-Id: I6f0afeeb41f667d780707af65034d5ba978f0d4a
---
 gnu/packages/bioconductor.scm | 50 +++++++++++++++++++++++++++++++++++
 1 file changed, 50 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 737d1ca2de..184972afb5 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -22308,6 +22308,56 @@  (define-public r-basic4cseq
 and a multi-scale contact profile.")
     (license license:lgpl3)))
 
+(define-public r-basics
+  (package
+    (name "r-basics")
+    (version "2.14.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "BASiCS" version))
+       (sha256
+        (base32 "0kf215n151sxphc5w9h4i2xsk7lmysi4abwcpyz4slbwhpki3ac8"))))
+    (properties `((upstream-name . "BASiCS")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-assertthat
+           r-biobase
+           r-biocgenerics
+           r-biocparallel
+           r-coda
+           r-cowplot
+           r-ggextra
+           r-ggplot2
+           r-hexbin
+           r-mass
+           r-matrix
+           r-matrixstats
+           r-posterior
+           r-rcpp
+           r-rcpparmadillo
+           r-reshape2
+           r-s4vectors
+           r-scran
+           r-scuttle
+           r-singlecellexperiment
+           r-summarizedexperiment
+           r-viridis))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/catavallejos/BASiCS")
+    (synopsis "Bayesian analysis of single-cell sequencing data")
+    (description
+     "@acronym{BASiCS, Bayesian analysis of single-cell sequencing data} is an
+integrated Bayesian hierarchical model to perform statistical analyses of
+single-cell RNA sequencing datasets in the context of supervised experiments
+(where the groups of cells of interest are known a priori.  BASiCS performs
+built-in data normalisation (global scaling) and technical noise quantification
+(based on spike-in genes).  BASiCS provides an intuitive detection criterion for
+highly (or lowly) variable genes within a single group of cells.  Additionally,
+BASiCS can compare gene expression patterns between two or more pre-specified
+groups of cells.")
+    (license license:gpl3)))
+
 (define-public r-basilisk-utils
   (package
     (name "r-basilisk-utils")