diff mbox series

[bug#66966,12/13] gnu: Add r-bbcanalyzer.

Message ID ef85d27aab8c0a93b89d2803130666f1ffe929ec.1699268809.git.madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#66966,01/13] gnu: Add r-breastcancervdx. | expand

Commit Message

Mădălin Ionel Patrașcu Nov. 6, 2023, 11:06 a.m. UTC
* gnu/packages/bioconductor.scm (r-bbcanalyzer): New variable.

Change-Id: Icd3c77c9522d73638ddb0934ad332ddb7b947a8e
---
 gnu/packages/bioconductor.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index a8fa9d7af4..384bb7cbdf 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -22550,6 +22550,36 @@  (define-public r-baynorm
 point estimates from posterior (2D array) or samples from posterior (3D array).")
     (license license:gpl2+)))
 
+(define-public r-bbcanalyzer
+  (package
+    (name "r-bbcanalyzer")
+    (version "1.32.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "BBCAnalyzer" version))
+       (sha256
+        (base32 "108jcgsf5hyj348y17hcw8m3zcfjgzpx8nz4n5jgxp2lgxjyizy1"))))
+    (properties `((upstream-name . "BBCAnalyzer")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-biostrings
+           r-genomicranges
+           r-iranges
+           r-rsamtools
+           r-summarizedexperiment
+           r-variantannotation))
+    (home-page "https://bioconductor.org/packages/BBCAnalyzer")
+    (synopsis "Visualizing base counts")
+    (description
+     "BBCAnalyzer is a package for visualizing the relative or absolute number
+of bases, deletions and insertions at defined positions in sequence alignment
+data available as bam files in comparison to the reference bases.  Markers for
+the relative base frequencies, the mean quality of the detected bases, known
+mutations or polymorphisms and variants called in the data may additionally be
+included in the plots.")
+    (license license:lgpl3)))
+
 (define-public r-biocthis
   (package
     (name "r-biocthis")