diff mbox series

[bug#66966,06/13] gnu: Add r-basicstarrseq.

Message ID ff69cac9ad46f92f2d6412f80ad65d8a9263b676.1699268809.git.madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#66966,01/13] gnu: Add r-breastcancervdx. | expand

Commit Message

Mădălin Ionel Patrașcu Nov. 6, 2023, 11:06 a.m. UTC
* gnu/packages/bioconductor.scm (r-basicstarrseq): New variable.

Change-Id: I88f314877ea4ab98976820a4acc337ae3a34e604
---
 gnu/packages/bioconductor.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 184972afb5..986227ec38 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -22358,6 +22358,39 @@  (define-public r-basics
 groups of cells.")
     (license license:gpl3)))
 
+(define-public r-basicstarrseq
+  (package
+    (name "r-basicstarrseq")
+    (version "1.30.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "BasicSTARRseq" version))
+       (sha256
+        (base32 "1dw6bv1qk2bn0l3m458sqgvm3s1karh4n3431pl7r0jj2r3mr6xa"))))
+    (properties `((upstream-name . "BasicSTARRseq")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-genomeinfodb
+           r-genomicalignments
+           r-genomicranges
+           r-iranges
+           r-s4vectors))
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/BasicSTARRseq")
+    (synopsis "Basic peak calling on STARR-seq data")
+    (description
+     "This package implements a method that aims to identify enhancers on large
+scale.  The STARR-seq data consists of two sequencing datasets of the same targets
+in a specifc genome.  The input sequences show which regions where tested for
+enhancers.  Significant enriched peaks i.e. a lot more sequences in one region
+than in the input where enhancers in the genomic DNA are, can be identified.  So
+the approach pursued is to call peak every region in which there is a lot more
+(significant in a binomial model) STARR-seq signal than input signal and propose
+an enhancer at that very same position.  Enhancers then are called weak or strong
+dependent of there degree of enrichment in comparison to input.")
+    (license license:lgpl3)))
+
 (define-public r-basilisk-utils
   (package
     (name "r-basilisk-utils")