diff mbox series

[bug#54335,v4,06/12] gnu: Add go-github-com-nbrownus-go-metrics-prometheus.

Message ID 20240211182830.3631-7-levenson@mmer.org
State New
Headers show
Series gnu: Add nebula. | expand

Commit Message

Alexey Abramov Feb. 11, 2024, 6:28 p.m. UTC
From: Dominic Martinez <dom@dominicm.dev>

* gnu/packages/golang.scm (go-github-com-nbrownus-go-metrics-prometheus): New
variable.
---
 gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 96ddb73d6a..56965e3394 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11793,6 +11793,34 @@  (define-public go-github-com-miekg-dns
 presenting a small interface.")
     (license license:bsd-3)))
 
+(define-public go-github-com-nbrownus-go-metrics-prometheus
+  (package
+    (name "go-github-com-nbrownus-go-metrics-prometheus")
+    (version "0.0.0-20210712211119-974a6260965f")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/nbrownus/go-metrics-prometheus")
+               (commit (go-version->git-ref version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "1kl9l08aas544627zmhkgp843qx94sxs4inxm20nw1hx7gp79dz0"))))
+    (build-system go-build-system)
+    (arguments '(#:import-path "github.com/nbrownus/go-metrics-prometheus"))
+    (propagated-inputs
+     (list go-github-com-stretchr-testify
+           go-github-com-rcrowley-go-metrics
+           go-github-com-prometheus-client-golang))
+    (home-page "https://github.com/nbrownus/go-metrics-prometheus")
+    (synopsis "Prometheus support for go-metrics")
+    (description
+      "@code{go-github-com-nbrownus-go-metrics-prometheus} is a reporter for
+the go-metrics library which will post the metrics to the prometheus client
+registry.  It just updates the registry, taking care of exporting the metrics
+is still your responsibility.")
+    (license license:asl2.0)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar