diff mbox series

[bug#54335,v4,03/12] gnu: Add go-github-com-cyberdelia-go-metrics-graphite.

Message ID 20240211182830.3631-4-levenson@mmer.org
State New
Headers show
Series gnu: Add nebula. | expand

Commit Message

Alexey Abramov Feb. 11, 2024, 6:28 p.m. UTC
From: Dominic Martinez <dom@dominicm.dev>

* gnu/packages/golang.scm (go-github-com-cyberdelia-go-metrics-graphite): New variable.
---
 gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6ca2d23f83..82bfcc1a46 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11709,6 +11709,34 @@  (define-public go-github-com-armon-go-radix
 provides a single @code{Tree} implementation, optimized for sparse nodes.")
     (license license:expat)))
 
+
+(define-public go-github-com-cyberdelia-go-metrics-graphite
+  (package
+    (name "go-github-com-cyberdelia-go-metrics-graphite")
+    (version "0.0.0-20161219230853-39f87cc3b432")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/cyberdelia/go-metrics-graphite")
+               (commit (go-version->git-ref version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "1nnpwryw8i110laffyavvhx38gcd1jnpdir69y6fxxzpx06d094w"))))
+    (build-system go-build-system)
+    (propagated-inputs
+     (list go-github-com-rcrowley-go-metrics))
+    (arguments
+     '(#:tests? #f ; Tests require network interface access
+       #:import-path "github.com/cyberdelia/go-metrics-graphite"))
+    (home-page "https://github.com/cyberdelia/go-metrics-graphite")
+    (synopsis "Graphite client for go-metrics")
+    (description
+      "@code{go-github-com-cyberdelia-go-metrics-graphite} is a reporter for
+the @url{https://github.com/rcrowley/go-metrics,go-metrics} library which
+posts metrics to Graphite.")
+    (license license:bsd-2)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar