diff mbox series

[bug#54335,v4,02/12] gnu: Add go-github-com-armon-go-radix.

Message ID 20240211182830.3631-3-levenson@mmer.org
State New
Headers show
Series gnu: Add nebula. | expand

Commit Message

Alexey Abramov Feb. 11, 2024, 6:28 p.m. UTC
From: Dominic Martinez <dom@dominicm.dev>

* gnu/packages/golang.scm (go-github-com-armon-go-radix): New variable.
---
 gnu/packages/golang.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8e6c629dc8..6ca2d23f83 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11686,6 +11686,29 @@  (define-public go-github-com-anmitsu-go-shlex
 analyzer to parse shell-like commands.")
     (license license:expat)))
 
+(define-public go-github-com-armon-go-radix
+  (package
+    (name "go-github-com-armon-go-radix")
+    (version "1.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/armon/go-radix")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1m1k0jz9gjfrk4m7hjm7p03qmviamfgxwm2ghakqxw3hdds8v503"))))
+    (build-system go-build-system)
+    (arguments '(#:import-path "github.com/armon/go-radix"))
+    (home-page "https://github.com/armon/go-radix")
+    (synopsis "Go implementation of Radix trees")
+    (description
+     "@code{go-github-com-armon-go-radix} implements a
+@url{http://en.wikipedia.org/wiki/Radix_tree,radix tree}. The package only
+provides a single @code{Tree} implementation, optimized for sparse nodes.")
+    (license license:expat)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar