diff mbox series

[bug#54335,v4,04/12] gnu: Add go-github-com-google-gopacket.

Message ID 20240211182830.3631-5-levenson@mmer.org
State New
Headers show
Series gnu: Add nebula. | expand

Commit Message

Alexey Abramov Feb. 11, 2024, 6:28 p.m. UTC
From: Dominic Martinez <dom@dominicm.dev>

* gnu/packages/golang.scm (go-github-com-google-gopacket): New variable
---
 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 82bfcc1a46..18812fb4c7 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11737,6 +11737,31 @@  (define-public go-github-com-cyberdelia-go-metrics-graphite
 posts metrics to Graphite.")
     (license license:bsd-2)))
 
+
+(define-public go-github-com-google-gopacket
+  (package
+    (name "go-github-com-google-gopacket")
+    (version "1.1.19")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/google/gopacket")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "048qwm2n0wrpql4qqgd7jyynn3gk069yvqbxnshlayzmbhf87ls4"))))
+    (build-system go-build-system)
+    (arguments '(#:import-path "github.com/google/gopacket"))
+    (propagated-inputs
+      (list go-golang-org-x-sys go-golang-org-x-net))
+    (home-page "https://github.com/google/gopacket")
+    (synopsis "Provides packet processing capabilities for Go")
+    (description
+      "@code{go-github-com-google-gopacket} provides packet decoding for the
+Go language.")
+    (license license:bsd-3)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar