diff mbox series

[bug#54335,v4,05/12] gnu: Add go-github-com-miekg-dns.

Message ID 20240211182830.3631-6-levenson@mmer.org
State New
Headers show
Series gnu: Add nebula. | expand

Commit Message

Alexey Abramov Feb. 11, 2024, 6:28 p.m. UTC
From: Dominic Martinez <dom@dominicm.dev>

* gnu/packages/golang.scm (go-github-com-miekg-dns): New variable.
---
 gnu/packages/golang.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 18812fb4c7..96ddb73d6a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11762,6 +11762,37 @@  (define-public go-github-com-google-gopacket
 Go language.")
     (license license:bsd-3)))
 
+
+(define-public go-github-com-miekg-dns
+  (package
+    (name "go-github-com-miekg-dns")
+    (version "1.1.48")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/miekg/dns")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "14m4wnbgmc1prj4ds1fsz1nwb1awaq365lhbp8clzsidxmhjf3hl"))))
+    (build-system go-build-system)
+    (arguments '(#:import-path "github.com/miekg/dns"))
+    (propagated-inputs
+     (list go-golang-org-x-tools
+           go-golang-org-x-sys
+           go-golang-org-x-sync
+           go-golang-org-x-net))
+    (home-page "https://github.com/miekg/dns")
+    (synopsis "Domain Name Service library in Go")
+    (description
+      "@code{go-github-com-miekg-dns} implements a fully featured interface to
+the Domain Name System.  Both server and client side programming is supported.
+The package allows complete control over what is sent out to the @acronym{DNS,
+Domain Name Service}.  The API follows the less-is-more principle, by
+presenting a small interface.")
+    (license license:bsd-3)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar