diff mbox series

[bug#54335,v4,01/12] gnu: Add go-github-com-anmitsu-go-shlex.

Message ID 20240211182830.3631-2-levenson@mmer.org
State New
Headers show
Series gnu: Add nebula. | expand

Commit Message

Alexey Abramov Feb. 11, 2024, 6:28 p.m. UTC
From: Dominic Martinez <dom@dominicm.dev>

* gnu/packages/golang.scm (go-github-com-anmitsu-go-shlex): New variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 163691a1e6..8e6c629dc8 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -44,6 +44,7 @@ 
 ;;; Copyright © 2023, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;; Copyright © 2023 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
+;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -11662,6 +11663,29 @@  (define-public go-github-com-onsi-gomega
      "Gomega is the preferred matcher library for the Ginkgo test framework.")
     (license license:expat)))
 
+
+(define-public go-github-com-anmitsu-go-shlex
+  (package
+    (name "go-github-com-anmitsu-go-shlex")
+    (version "0.0.0-20200514113438-38f4b401e2be")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/anmitsu/go-shlex")
+               (commit (go-version->git-ref version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "17iz68yzbnr7y4s493asbagbv79qq8hvl2pkxvm6bvdkgphj8w1g"))))
+    (build-system go-build-system)
+    (arguments '(#:import-path "github.com/anmitsu/go-shlex"))
+    (home-page "https://github.com/anmitsu/go-shlex")
+    (synopsis "Simple shell-like lexical analyzer for Go")
+    (description
+      "@code{go-github-com-anmitsu-go-shlex} provides a simple lexical
+analyzer to parse shell-like commands.")
+    (license license:expat)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar