diff mbox series

[bug#64134,07/17] gnu: Add python-pyhdfe.

Message ID 20230617151840.1748096-7-monego@posteo.net
State New
Headers show
Series Add some Python financial libraries. | expand

Commit Message

Vinicius Monego June 17, 2023, 3:18 p.m. UTC
* gnu/packages/statistics.scm (python-pyhdfe): New variable.
---
 gnu/packages/statistics.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 67466ed3b9..9337a40f7b 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -6634,6 +6634,26 @@  (define-public r-languageserver
 completion.")
       (license license:expat))))
 
+(define-public python-pyhdfe
+  (package
+    (name "python-pyhdfe")
+    (version "0.1.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "pyhdfe" version))
+              (sha256
+               (base32
+                "0cl4i0irc13r5z73lasfwi75zq9wk56r93h26crm0r9ajb8fa1m9"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-numpy python-scipy))
+    (native-inputs (list python-pytest python-pytest-xdist))
+    (home-page "https://github.com/jeffgortmaker/pyhdfe")
+    (synopsis "High dimensional fixed effect absorption")
+    (description
+     "PyHDFE is a Python 3 implementation of algorithms for absorbing high
+dimensional fixed effects.")
+     (license license:expat)))
+
 (define-public python-rpy2
   (package
     (name "python-rpy2")