diff mbox series

[bug#64134,13/17] gnu: Add python-detecta.

Message ID 20230617151840.1748096-13-monego@posteo.net
State New
Headers show
Series Add some Python financial libraries. | expand

Commit Message

Vinicius Monego June 17, 2023, 3:18 p.m. UTC
* gnu/packages/python-science.scm (python-detecta): New variable.
---
 gnu/packages/python-science.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index fb2ea0c3b5..ca0d0e5941 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -532,6 +532,28 @@  (define-public python-pythran
 Python module with the same interface, but (hopefully) faster.")
     (license license:bsd-3)))
 
+(define-public python-detecta
+  (package
+    (name "python-detecta")
+    (version "0.0.5")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "detecta" version))
+              (sha256
+               (base32
+                "1v830v258vn59sk15rx8m1sycpx8q26pyniqrvb99jdvvw9pvsnj"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:tests? #f)) ; no tests
+    (propagated-inputs (list python-numpy))
+    (home-page "https://github.com/demotu/detecta")
+    (synopsis "Detect events in data")
+    (description
+     "This package provides a Python module to detect events in data, such as
+peaks, onset, abrupt changes, initial and final indices of sequential data
+identical to a parameter.")
+    (license license:expat)))
+
 (define-public python-pyts
   (package
     (name "python-pyts")