diff mbox series

[bug#64134,16/17] gnu: Add python-pandas-ta.

Message ID 20230617151840.1748096-16-monego@posteo.net
State New
Headers show
Series Add some Python financial libraries. | expand

Commit Message

Vinicius Monego June 17, 2023, 3:18 p.m. UTC
* gnu/packages/finance.scm (python-pandas-ta): New variable.
---
 gnu/packages/finance.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 31292c2863..e727681014 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1148,6 +1148,40 @@  (define-public python-mstarpy
 provides stock and fund public data to retail and professional investors.")
     (license license:expat)))
 
+(define-public python-pandas-ta
+  (package
+    (name "python-pandas-ta")
+    (version "0.3.14")
+    (source (origin
+              (method git-fetch)        ;no tests in PyPI
+              (uri (git-reference
+                    (url "https://github.com/twopirllc/pandas-ta")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "04903n1kizhhibyipcd8c7wwyvbayhvf3zch42axxrqd9axkzknn"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:test-flags #~(list "-k" "not test_custom_a"))) ;this test failed
+    (native-inputs (list python-pytest))
+    (propagated-inputs (list python-dateutil
+                             python-numpy
+                             python-pandas
+                             python-pytz
+                             python-ta-lib))
+    (home-page "https://github.com/twopirllc/pandas-ta")
+    (synopsis "Pandas Extension with 130+ Technical Analysis Indicators")
+    (description
+     "Pandas Technical Analysis (Pandas TA) is a library that leverages the
+Pandas package with more than 130 Indicators and Utility functions and more
+than 60 TA Lib Candlestick Patterns.  Many commonly used indicators are
+included, such as: Candle Pattern(cdl_pattern), Simple Moving Average (sma),
+Moving Average Convergence Divergence (macd), Hull Exponential Moving Average
+(hma), Bollinger Bands (bbands), On-Balance Volume (obv), Aroon & Aroon
+Oscillator (aroon), Squeeze (squeeze) and many more.")
+    (license license:expat)))
+
 (define-public python-mnemonic
   (package
     (name "python-mnemonic")