diff mbox series

[bug#64134,10/17] gnu: Add python-alpha-vantage.

Message ID 20230617151840.1748096-10-monego@posteo.net
State New
Headers show
Series Add some Python financial libraries. | expand

Commit Message

Vinicius Monego June 17, 2023, 3:18 p.m. UTC
* gnu/packages/finance.scm (python-alpha-vantage): New variable.
---
 gnu/packages/finance.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 9c18e103b7..5a655e3dfa 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1051,6 +1051,27 @@  (define-public python-arch
 (ARCH) and other tools for financial econometrics.")
     (license license:expat)))
 
+(define-public python-alpha-vantage
+  (package
+    (name "python-alpha-vantage")
+    (version "2.3.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "alpha_vantage" version))
+              (sha256
+               (base32
+                "1v7vkd2rkz52lilprbpq3sj4yfpcjl0xksmcpndjz8p2qc46krqc"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:tests? #f)) ;this is an API library (online tests)
+    (propagated-inputs (list python-aiohttp python-requests))
+    (home-page "https://github.com/RomelTorres/alpha_vantage")
+    (synopsis "Get stock data from the Alpha Vantage API")
+    (description
+     "This package provides a Python module to get stock data from the Alpha
+Vantage API.")
+    (license license:expat)))
+
 (define-public python-mnemonic
   (package
     (name "python-mnemonic")