diff mbox series

[bug#64134,01/17] gnu: Add python-holidays.

Message ID 20230617151840.1748096-1-monego@posteo.net
State New
Headers show
Series Add some Python financial libraries. | expand

Commit Message

Vinicius Monego June 17, 2023, 3:18 p.m. UTC
* gnu/packages/python-xyz.scm (python-holidays): New variable.
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9ba17c509b..51e6da8d21 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30797,6 +30797,28 @@  (define-public python-csb43
 spreadsheet), CSV, TSV, XLS, XLSX (Microsoft Excel spreadsheet), and YAML.")
     (license license:lgpl3)))
 
+(define-public python-holidays
+  (package
+    (name "python-holidays")
+    (version "0.26")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "holidays" version))
+              (sha256
+               (base32
+                "05c999q41b41av061l1j6kk4ys0jcdpby0iqgmqzrj2ljwd43y73"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-pytest))
+    (propagated-inputs (list python-dateutil))
+    (home-page "https://github.com/dr-prodigy/python-holidays")
+    (synopsis "Generate and work with holidays in Python")
+    (description
+     "This package provides a Python library for generating country- and
+subdivision- (e.g. state or province) specific sets of government-designated
+holidays on the fly.  It aims to make determining whether a specific date is
+a holiday as fast and flexible as possible.")
+    (license license:expat)))
+
 (define-public python-febelfin-coda
   (package
     (name "python-febelfin-coda")