diff mbox series

[bug#64134,05/17] gnu: Add python-ffn.

Message ID 20230617151840.1748096-5-monego@posteo.net
State New
Headers show
Series Add some Python financial libraries. | expand

Commit Message

Vinicius Monego June 17, 2023, 3:18 p.m. UTC
* gnu/packages/finance.scm (python-ffn): New variable.
---
 gnu/packages/finance.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 7eaa5941a0..94f7b2111f 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -103,6 +103,7 @@  (define-module (gnu packages finance)
   #:use-module (gnu packages libunwind)
   #:use-module (gnu packages libusb)
   #:use-module (gnu packages linux)
+  #:use-module (gnu packages machine-learning)
   #:use-module (gnu packages man)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages mpi)
@@ -1094,6 +1095,41 @@  (define-public python-pandas-datareader
      "This package provides up to date remote data access for Pandas.")
     (license license:bsd-3)))
 
+(define-public python-ffn
+  (package
+    (name "python-ffn")
+    (version "0.3.7")
+    (source (origin
+               ;PyPI is missing files required for testing
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/pmorissette/ffn")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0rq6w2hbf8mcc9blrdf6aj7fnrcj0bvza2y4miznv3il9wqnpd6z"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-decorator
+                             python-matplotlib
+                             python-numpy
+                             python-pandas
+                             python-pandas-datareader
+                             python-scikit-learn
+                             python-scipy
+                             python-tabulate
+                             python-yfinance))
+    (native-inputs (list python-black python-codecov python-flake8
+                         python-pytest python-pytest-cov))
+    (home-page "https://github.com/pmorissette/ffn")
+    (synopsis "Financial functions for Python")
+    (description
+     "@code{ffn} is a library that contains many useful functions
+ for those who work in quantitative finance.  It provides a vast array of
+utilities, from performance measurement and evaluation to graphing and common
+data transformations.")
+    (license license:expat)))
+
 (define-public python-u2flib-host
   ;; The package is obsolete and superseded by python-fido2, but
   ;; needed for python-ledgerblue@0.1.44.