diff mbox series

[bug#61420,28/31] gnu: pandoc: Drop Haskell libraries and documentation.

Message ID 20230211100825.47971-25-lars@6xq.net
State New
Headers show
Series Haskell upgrade to Stackage 20.5 | expand

Commit Message

Lars-Dominik Braun Feb. 11, 2023, 10:08 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-pandoc): Renamed from pandoc.
(pandoc) [arguments]: Add 'remove-libraries phase and disable #:haddock?.
---
 gnu/packages/haskell-xyz.scm | 19 +++++++++++++++----
 1 file changed, 15 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 0a6efedd29..7578065eb1 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -8188,9 +8188,9 @@  (define-public ghc-doclayout
 code.  It was designed for use in @code{Pandoc}.")
     (license license:bsd-3)))
 
-(define-public pandoc
+(define-public ghc-pandoc
   (package
-    (name "pandoc")
+    (name "ghc-pandoc")
     (version "2.19.2")
     (source (origin
               (method url-fetch)
@@ -8288,8 +8288,19 @@  (define-public pandoc
 provided for those who need a drop-in replacement for Markdown.pl.")
     (license license:gpl2+)))
 
-(define-public ghc-pandoc
-  (deprecated-package "ghc-pandoc" pandoc))
+(define-public pandoc
+  (package
+    (inherit ghc-pandoc)
+    (name "pandoc")
+    (arguments
+     (list
+       #:phases
+       #~(modify-phases %standard-phases
+           (add-after 'register 'remove-libraries
+             (lambda* (#:key outputs #:allow-other-keys)
+               (delete-file-recursively (string-append (assoc-ref outputs "out") "/lib")))))
+       ;; Haddock documentation is for the library.
+       #:haddock? #f))))
 
 (define-public ghc-pandoc-types
   (package