diff mbox series

[bug#61420,23/31] gnu: ngless: Drop Haskell libraries and documentation.

Message ID 20230211100825.47971-20-lars@6xq.net
State New
Headers show
Series Haskell upgrade to Stackage 20.5 | expand

Commit Message

Lars-Dominik Braun Feb. 11, 2023, 10:08 a.m. UTC
* gnu/packages/bioinformatics.scm (ngless)[arguments]: Add
'remove-libraries phase and disable #:haddock?.
---
 gnu/packages/bioinformatics.scm | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 3e2d1efc87..8eb164d24b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14316,7 +14316,8 @@  (define-public ngless
                 "0pljyrlpr9r3cl5311dhgxdl8y40szyi4vprn34i3piy0qrldymi"))))
     (build-system haskell-build-system)
     (arguments
-     `(#:phases
+     `(#:haddock? #f
+       #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'update-constraints
            (lambda _
@@ -14360,7 +14361,10 @@  (define-public ngless
           (add-after 'wrap-program 'check-install
              (lambda* (#:key outputs #:allow-other-keys)
                (let* ((ngless (string-append (assoc-ref outputs "out") "/bin/ngless")))
-                 (invoke ngless "--check-install")))))))
+                 (invoke ngless "--check-install"))))
+          (add-after 'register 'remove-libraries
+            (lambda* (#:key outputs #:allow-other-keys)
+              (delete-file-recursively (string-append (assoc-ref outputs "out") "/lib")))))))
     (inputs (list prodigal
                   bwa
                   samtools