diff mbox series

[bug#61420,14/31] gnu: ghc-9.2: Increase make verbosity.

Message ID 20230211100825.47971-11-lars@6xq.net
State New
Headers show
Series Haskell upgrade to Stackage 20.5 | expand

Commit Message

Lars-Dominik Braun Feb. 11, 2023, 10:08 a.m. UTC
Tests time out on ci.guix.gnu.org.

* gnu/packages/haskell.scm (ghc-9.2)[arguments]: Modify #:make-flags.
---
 gnu/packages/haskell.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

Comments

Simon Tournier Feb. 15, 2023, 10:53 a.m. UTC | #1
Hi,

On Sat, 11 Feb 2023 at 11:08, Lars-Dominik Braun <lars@6xq.net> wrote:
> Tests time out on ci.guix.gnu.org.

[...]

> +         ;; Increase verbosity, so running the test suite does not time out on CI.

Hehe!  Well, I think there is variable for that.  Something like:

      (properties
       `((max-silent-time . 36000)))

Well, one is not exclusive with the other. :-)


Cheers,
simon
diff mbox series

Patch

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 84071cb293..60d846e841 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1295,7 +1295,10 @@  (define-public ghc-9.2
              (replace 'fix-cc-reference
                (lambda _
                  (substitute* "utils/hsc2hs/src/Common.hs"
-                   (("\"cc\"") "\"gcc\""))))))))
+                   (("\"cc\"") "\"gcc\""))))))
+         ;; Increase verbosity, so running the test suite does not time out on CI.
+         ((#:make-flags make-flags ''())
+          #~(cons "VERBOSE=4" #$make-flags))))
       (native-inputs
        `(;; GHC 9.2 must be built with GHC >= 8.6.
          ("ghc-bootstrap" ,base)