diff mbox series

[bug#61420,15/31] gnu: Remove unused Haskell packages.

Message ID 20230211100825.47971-12-lars@6xq.net
State New
Headers show
Series Haskell upgrade to Stackage 20.5 | expand

Commit Message

Lars-Dominik Braun Feb. 11, 2023, 10:08 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-attoparsec-bootstrap): Remove variable.
(ghc-integer-logarithms-bootstrap): Likewise.
(ghc-scientific-bootstrap): Likewise.
(ghc-wcwidth-bootstrap): Likewise.
(ghc-optparse-applicative-0.15.1.0): Likewise.
---
 gnu/packages/haskell-xyz.scm | 59 ------------------------------------
 1 file changed, 59 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 1f90cc6516..f320206c23 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -581,16 +581,6 @@  (define-public ghc-attoparsec
 complicated text/binary file formats.")
     (license license:bsd-3)))
 
-(define-public ghc-attoparsec-bootstrap
-  (package
-    (inherit ghc-attoparsec)
-    (name "ghc-attoparsec-bootstrap")
-    (arguments `(#:tests? #f))
-    (inputs
-     `(("ghc-scientific" ,ghc-scientific-bootstrap)))
-    (native-inputs '())
-    (properties '((hidden? #t)))))
-
 (define-public ghc-attoparsec-iso8601
   (package
     (name "ghc-attoparsec-iso8601")
@@ -5825,14 +5815,6 @@  (define-public ghc-integer-logarithms
 in migrated modules.")
     (license license:expat)))
 
-(define-public ghc-integer-logarithms-bootstrap
-  (package
-    (inherit ghc-integer-logarithms)
-    (name "ghc-integer-logarithms-bootstrap")
-    (arguments `(#:tests? #f))
-    (native-inputs '())
-    (properties '((hidden? #t)))))
-
 (define-public ghc-interpolate
   (package
     (name "ghc-interpolate")
@@ -8051,27 +8033,6 @@  (define-public ghc-optparse-applicative
 command line options in Haskell.")
     (license license:bsd-3)))
 
-(define-public ghc-optparse-applicative-0.15.1.0
-  (package
-    (inherit ghc-optparse-applicative)
-    (name "ghc-optparse-applicative")
-    (version "0.15.1.0")
-    (source
-      (origin
-        (method url-fetch)
-        (uri (string-append
-               "https://hackage.haskell.org/package/optparse-applicative/optparse-applicative-"
-               version
-               ".tar.gz"))
-        (sha256
-          (base32 "1ws6y3b3f6hsgv0ff0yp6lw4hba1rps4dnvry3yllng0s5gngcsd"))))
-    (inputs
-      (list ghc-transformers-compat ghc-ansi-wl-pprint))
-    (native-inputs (list ghc-quickcheck))
-    (arguments
-      `(#:cabal-revision
-        ("1" "0zmhqkd96v2z1ilhqdkd9z4jgsnsxb8yi2479ind8m5zm9363zr9")))))
-
 (define-public ghc-jira-wiki-markup
   (package
     (name "ghc-jira-wiki-markup")
@@ -10178,18 +10139,6 @@  (define-public ghc-scientific
 notation}.")
     (license license:bsd-3)))
 
-(define-public ghc-scientific-bootstrap
-  (package
-    (inherit ghc-scientific)
-    (name "ghc-scientific-bootstrap")
-    (arguments `(#:tests? #f))
-    (inputs
-     `(("ghc-integer-logarithms" ,ghc-integer-logarithms-bootstrap)
-       ("ghc-hashable" ,ghc-hashable)
-       ("ghc-primitive" ,ghc-primitive)))
-    (native-inputs '())
-    (properties '((hidden? #t)))))
-
 (define-public ghc-sdl
   (package
     (name "ghc-sdl")
@@ -13422,14 +13371,6 @@  (define-public ghc-wcwidth
 widths to the Char type.")
     (license license:bsd-3)))
 
-(define-public ghc-wcwidth-bootstrap
-  (package
-    (inherit ghc-wcwidth)
-    (name "ghc-wcwidth-bootstrap")
-    (inputs
-     (list ghc-setlocale ghc-utf8-string ghc-attoparsec-bootstrap))
-    (properties '((hidden? #t)))))
-
 (define-public ghc-weigh
   (package
     (name "ghc-weigh")