diff mbox series

[bug#61420,27/31] gnu: shellcheck: Drop Haskell libraries.

Message ID 20230211100825.47971-24-lars@6xq.net
State New
Headers show
Series Haskell upgrade to Stackage 20.5 | expand

Commit Message

Lars-Dominik Braun Feb. 11, 2023, 10:08 a.m. UTC
* gnu/packages/haskell-apps.scm (shellcheck)[arguments]: Add
'remove-libraries phase.
---
 gnu/packages/haskell-apps.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 80abc99cb1..35e369df3f 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -836,7 +836,10 @@  (define-public shellcheck
            (lambda* (#:key outputs #:allow-other-keys)
              (install-file "shellcheck.1"
                            (string-append (assoc-ref outputs "out")
-                                          "/share/man/man1/")))))))
+                                          "/share/man/man1/"))))
+         (add-after 'register 'remove-libraries
+           (lambda* (#:key outputs #:allow-other-keys)
+             (delete-file-recursively (string-append (assoc-ref outputs "out") "/lib")))))))
     (native-inputs
      (list pandoc))
     (inputs