diff mbox series

[bug#61420,26/31] gnu: git-annex: Drop Haskell documentation.

Message ID 20230211100825.47971-23-lars@6xq.net
State New
Headers show
Series Haskell upgrade to Stackage 20.5 | expand

Commit Message

Lars-Dominik Braun Feb. 11, 2023, 10:08 a.m. UTC
* gnu/packages/haskell-apps.scm (git-annex)[arguments]: Disable #:haddock?.
---
 gnu/packages/haskell-apps.scm | 13 ++-----------
 1 file changed, 2 insertions(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 7189d82ec1..80abc99cb1 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -306,6 +306,7 @@  (define-public git-annex
     (arguments
      `(#:configure-flags
        '("--flags=-Android -Webapp")
+       #:haddock? #f
        #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'patch-shell-for-tests
@@ -386,17 +387,7 @@  (define-public git-annex
                (symlink (string-append bin "/git-annex")
                         (string-append bin "/git-annex-shell"))
                (symlink (string-append bin "/git-annex")
-                        (string-append bin "/git-remote-tor-annex")))))
-         (add-after 'install 'touch-static-output
-           (lambda* (#:key outputs #:allow-other-keys)
-             ;; The Haskell build system adds a "static" output by
-             ;; default, and there is no way to override this until
-             ;; <https://issues.guix.gnu.org/41569> is fixed.  Without
-             ;; this phase, the daemon complains because we do not
-             ;; create the "static" output.
-             (with-output-to-file (assoc-ref outputs "static")
-               (lambda ()
-                 (display "static output not used\n"))))))))
+                        (string-append bin "/git-remote-tor-annex"))))))))
     (inputs
      (list curl
            ghc-aeson