diff mbox series

[bug#59911,7/7] gnu: Add r-wpm.

Message ID 20221208211322.28459-7-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#59911,1/7] gnu: Add r-logging. | expand

Commit Message

Mădălin Ionel Patrașcu Dec. 8, 2022, 9:13 p.m. UTC
* gnu/packages/bioconductor.scm (r-wpm): New variable.
---
 gnu/packages/bioconductor.scm | 42 +++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c62c5970b8..21b69cab01 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -12244,6 +12244,48 @@  (define-public r-wppi
 scores and a path search algorithm.")
     (license license:expat)))
 
+(define-public r-wpm
+  (package
+    (name "r-wpm")
+    (version "1.8.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "wpm" version))
+              (sha256
+               (base32
+                "05zpj0i4741xn1g0yhkq3mg9zjppfryrfc47pxnys9bjfij0az52"))))
+    (properties `((upstream-name . "wpm")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-biobase
+           r-cli
+           r-config
+           r-dplyr
+           r-dt
+           r-ggplot2
+           r-golem
+           r-logging
+           r-rcolorbrewer
+           r-rlang
+           r-shiny
+           r-shinycustomloader
+           r-shinydashboard
+           r-shinywidgets
+           r-stringr
+           r-summarizedexperiment))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/HelBor/wpm")
+    (synopsis "Generating well plate maker")
+    (description
+     "The @acronym{WPM, Well-Plate Maker} is a Shiny application deployed as an
+R package.  Functions for a command-line/script use are available.  The WPM allows
+users to generate well plate maps to carry out their experiments while improving
+the handling of batch effects.  In particular, it helps controlling the \"plate
+effect\" thanks to its ability to randomize samples over multiple well plates.
+The algorithm for placing the samples is inspired by the backtracking algorithm:
+the samples are placed at random while respecting specific spatial constraints.")
+    (license license:artistic2.0)))
+
 (define-public r-wrench
   (package
     (name "r-wrench")