diff mbox series

[bug#59911,3/7] gnu: Add r-anytime.

Message ID 20221208211322.28459-3-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#59911,1/7] gnu: Add r-logging. | expand

Commit Message

Mădălin Ionel Patrașcu Dec. 8, 2022, 9:13 p.m. UTC
* gnu/packages/cran.scm (r-anytime): New variable.
---
 gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1a5bef3cdb..b9d5757795 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -25484,6 +25484,30 @@  (define-public r-anthropometry
 statistical shape analysis and archetypal analysis.")
     (license license:gpl2+)))
 
+(define-public r-anytime
+  (package
+    (name "r-anytime")
+    (version "0.3.9")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "anytime" version))
+              (sha256
+               (base32
+                "0jjpqynai5nd7mfy1smb44356f3d5bmpxhs1i9x9jw5c959c35hh"))))
+    (properties `((upstream-name . "anytime")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-bh
+           r-rcpp))
+    (home-page "http://dirk.eddelbuettel.com/code/anytime.html")
+    (synopsis "Converter of input to POSIXct or Date")
+    (description
+     "The package converts the input in any one of character, integer, numeric,
+factor, or an ordered type into @code{POSIXct} (or @code{Date}) objects, using
+one of a number of predefined formats, and relying on Boost facilities for date
+and time parsing.")
+    (license license:gpl2+)))
+
 (define-public r-anndata
   (package
     (name "r-anndata")