diff mbox series

[bug#59911,4/7] gnu: Add r-shinywidgets.

Message ID 20221208211322.28459-4-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#59911,1/7] gnu: Add r-logging. | expand

Commit Message

Mădălin Ionel Patrașcu Dec. 8, 2022, 9:13 p.m. UTC
* gnu/packages/cran.scm (r-shinywidgets): New variable.
---
 gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Ricardo Wurmus Dec. 12, 2022, 5:49 p.m. UTC | #1
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

> * gnu/packages/cran.scm (r-shinywidgets): New variable.

This cannot be added as is.  We have had this package in the Guix
Science channel for a while now because it contains massive amounts of
minified JavaScript, sometimes without an obvious source.

Have you perhaps taken a look at some of these JavaScript files yet?
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b9d5757795..9cfca2f4ca 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -25810,6 +25810,33 @@  (define-public r-shinycssloaders
 automatically show a loader when the output is (re)calculating.")
     (license license:gpl3)))
 
+(define-public r-shinywidgets
+  (package
+    (name "r-shinywidgets")
+    (version "0.7.5")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "shinyWidgets" version))
+              (sha256
+               (base32
+                "1ls28r6dbvi4pml1mxakn327dzl0l71pkaw5rm9n80jd5npq9vmz"))))
+    (properties `((upstream-name . "shinyWidgets")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-anytime
+           r-bslib
+           r-htmltools
+           r-jsonlite
+           r-rlang
+           r-sass
+           r-shiny))
+    (home-page "https://github.com/dreamRs/shinyWidgets")
+    (synopsis "Custom input widgets for Shiny")
+    (description
+     "The package offers a collection of custom input controls and user interface
+components for Shiny applications.")
+    (license license:gpl3)))
+
 (define-public r-rsvg
   (package
     (name "r-rsvg")